How to fix ‚PLAN_TABLE‘ is old version

During a lot of SQL Performance activities I saw all the time the following message but why?


Note
-----
- 'PLAN_TABLE' is old version

Yes, I did a few days before an Upgrade from 11.2.0.4 -> 12.1.0.2. Now I start to check out some important SQL Queries but I the „old version“ message


sqlplus

set autotrace traceonly explain

select * from dual;

and again

Note ------

'PLAN_TABLE' is old version

Problem is that this message came up while the plan_table came from the previous version in my case 11.2.0.4. So the solution for this is very easy


In the new environment here 12.1.0.2
SQL> connect sys as sysdba

SQL> drop table plan_table$;

SQL> @?/rdbms/admin/catplan

This shoud fix the problem and if not?

Okay it could be possible that you should drop the plan_table as Schema User  and then run the the SQL again.

 


Here an example output:
Note
-----
- dynamic statistics used: dynamic sampling (level=2)
- automatic DOP: Computed Degree of Parallelism is 8 because of degree limit
- parallel scans affinitized for buffer cache


 

 

 

Advertisements

Kommentar verfassen

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden /  Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden /  Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden /  Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden /  Ändern )

w

Verbinde mit %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.